Installation of gpu enabled xgboost from source, cuda 10.2, ubuntu 18.04

My machine is a 18.04 ubuntu, with the nvidia gpu RTX 2080 (laptop), the driver is 440.33.01.
I had installed xgboost 1.6.0 from source (gpu enabled) 1 year ago, the whole process + troubleshooting took me 1 or 2 hrs, but eventually it all got installed and ran great!
Last week I tried to upgrade xgboost to 2.0.0 from source (gpu enabled). I tried cmake commands as well as using the python package.
The xgboost installation fails with the following error:
[ 93%] Building CUDA object src/CMakeFiles/objxgboost.dir/tree/gpu_hist/
/usr/local/cuda-10.2/bin/…/targets/x86_64-linux/include/thrust/detail/tuple.inl(324): error: function “thrust::cuda_cub::transform_input_iterator_t<ValueType, InputIt, UnaryOp>::operator=(const thrust::cuda_cub::transform_input_iterator_t<__nv_bool, thrust::counting_iterator<size_t, thrust::use_default, thrust::use_default, thrust::use_default>, lambda ->__nv_bool> &) [with ValueType=__nv_bool, InputIt=thrust::counting_iterator<size_t, thrust::use_default, thrust::use_default, thrust::use_default>, UnaryOp=lambda ->__nv_bool]” (declared implicitly) cannot be referenced – it is a deleted function
detected during:
… + more

Does anybody have any idea: is it even possible to install xgboost 2.0.0 (gpu enabled) with cuda 10.2 ? Thanks, A.

We don’t support CUDA 10 any more. Please upgrade to the latest CUDA