LZ4 version error after XGBoost version upgrading to v0.82


#1

Hi all, I’m trying to find the version of lz4 used in v0.82. I met following error after I upgrading xgboost version from v0.81 to v0.82

I’m using the spark 2.3.1, everything works well before upgrading, so I think maybe v0.82 use the new version of lz4 which has conflict with other dependencies.
Can anybody help me with this?

Thank you so much!


#2

Are you using Maven for your JVM build? Maven should resolve all dependencies. Can you run

mvn dependency:tree -Dverbose -Dincludes=commons-collections

to show dependency tree?


#3

I’m using SBT.
I found this lz4 issue was magically resolved when I re-run the code this morning…