Problems building XGBoost w/ GPU support for R


#1

Howdy everyone,

I’ve been struggling for the past two days to install XGBoost with GPU support for R. I’ve exhausted almost everything I could think of or find on here, the official docs, and on stack overflow.

I’ll try to be as comprehensive as possible!

System
CPU: i7-7820X
GPU: Nvidia RTX 2080

Environment (done on fresh install of Windows 10)
Operating System: Windows 10 Pro
Visual studio: Visual Studio 2017 (also tried Visual Studio 2015)
Cmake: cmake 3.13.1 (tried several older versions of cmake as well)
R: R 3.5.1 (also tried 3.3.1, 3.4.3, and a patched 3.4.3)

  • I made sure the correct path was set in the environment settings

Rtools: Rtools35

  • I made sure the correct paths were set to the Rtools bin and the mingw64 bin

CUDA: Downloaded the newest CUDA Toolkit

Steps to producing error

The following steps all complete without error:

git clone --recursive https://github.com/dmlc/xgboost
cd xgboost
git submodule init
git submodule update
mkdir build
cd build
cmake … -DUSE_CUDA=ON -DUSE_NCCL=OFF -DR_LIB=ON

I have also used the following variations without luck before building:

cmake … -G"Visual Studio 15 2017 Win64" -DUSE_CUDA=ON -DR_LIB=ON
cmake … -G"Visual Studio 14 2015 Win64" -DUSE_CUDA=ON -DR_LIB=ON

When I enter the following:

cmake --build . --target install --config Release

I get the following error message:

“C:\Users\John Kilbride\xgboost\build\install.vcxproj” (default target) (1) ->
“C:\Users\John Kilbride\xgboost\build\ALL_BUILD.vcxproj” (default target) (3) ->
“C:\Users\John Kilbride\xgboost\build\gpuxgboost.vcxproj” (default target) (5) ->
(CustomBuild target) ->
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(20
9,5): error MSB6006: “cmd.exe” exited with code 1. [C:\Users\John Kilbride\xgboost\build\gpuxgboost.vcxproj]

563 Warning(s)
1 Error(s)

Time Elapsed 00:00:23.24

The text for the warnings is massive. If that will be useful I can create a link to a pastebin/host a .txt somewhere!

I’ve run out of ideas for what to do. I’ve tried using different versions of the software to match the docs as closely as possible w/out luck. I’ve also tried a TON of variations based on what other people had luck using.

Other instances of people talking about this issue concluded with them downloading the unofficial pre-compiled versions which doesn’t exist to my knowledge for R.


#2

Can you put up the complete log for error?


#3

Hello hcho3,

Sorry for the wait! Here is a pastebin link:

https://pastebin.com/2Kf0CEZa

It is extremely long but I will refer you to line 436 where the major error appears to have occurred.

Thank you,
Jack


#4

Somehow the build is trying to use 32 bit, which is not supported. Are you using 64 bit processor and Windows? Is your R 64 bit?


#5

Weird!

I’m using this processor: Intel Core i7-7820X

And I installed the lastest version of R. Running this command:

bigint <- integer(2^32 / 4)

in R yilds a very large integer (~4gb in memory and suggests my R implementation is 64-bit as well).

My widows install is 64-bit (Windows 10 Pro).

This is pushing my PC knowledge but is there a 32-bit compiler it could be erroneously pointing to?