Can't turn off the validation messages during training

Hi all, I was train a XGBClassifer with early stopping, so the eval_metrix and eval_set were both set. I set the verbosity=0 in both XGBClassifier and xgb.config_context(), but it still prints every validation results like this:

[0] validation_0-logloss:0.53399
[0] validation_0-logloss:0.53152
[0] validation_0-logloss:0.63346
[0] validation_0-logloss:0.54667
[0] validation_0-logloss:0.53152
[0] validation_0-logloss:0.63372
[0] validation_0-logloss:0.53399
[1] validation_0-logloss:0.44288
[0] validation_0-logloss:0.63795
[1] validation_0-logloss:0.58414
[1] validation_0-logloss:0.44288
[1] validation_0-logloss:0.58452
[0] validation_0-logloss:0.63387
[1] validation_0-logloss:0.59179
[1] validation_0-logloss:0.58478
[0] validation_0-logloss:0.63517
[0] validation_0-logloss:0.62940
[0] validation_0-logloss:0.63530
[1] validation_0-logloss:0.58478
[1] validation_0-logloss:0.58487
[0] validation_0-logloss:0.62926

I’m on xgboost 1.40, is there anyway to prevent it from printing those results. Thanks

Can you post your code?

Hi, thanks for your reply, I’ve solved the problem by setting the the verbose_eval=False in the fit function, apparently the validation message is controlled by a diffferent verbosity setting.

clf.fit(X, y, verbose_eval=False)