Turn off train rmse log in train fnuction


#1

hello everyone,
i am using xgboost4j in a spring boot application and for making train log silent i set both parameter verbosity = 0 and silent = 1 (i know silent is deprecated as documentation said), but when i run the train function “train-rmse:1…” logs are being written in output console,
what should i do for turning the log completely off.


#2

Try setting disable_default_eval_metric parameter to 1.